免費論壇 繁體 | 簡體
Sclub交友聊天~加入聊天室當版主
返回列表 發帖
谢谢楼主分享

TOP

支持!謝謝分享
上磜网
http://zhu0753.66rt.com

TOP

感謝分享<3

TOP

不错,感谢分享

TOP

謝謝分享

TOP

谢谢分享!w

TOP

這個不錯~可以提醒到一些新人

TOP

.版本 2
.支持库 spec

.局部变量 hwnd_登录器


游戏帐号 = “2201059410”
游戏密码 = “mjxke5100”

游戏绝对路径 = “F:\网络游戏\地下城与勇士\_Dnf_登陆器.exe”

游戏启动进程名为 = “_Dnf_登陆器.exe”




pid = 取进程ID (游戏启动进程名为)


.如果真 (取进程ID (“DNF.exe”) ≠ -1)

    ' 信息框 (“游戏已经存在 不用执行登录了”, 0, , )


    .如果真 (FindWindowA子窗口_整数_文本 (0, “DNF Taiwan”) ≠ -1)  ' DNF.exe既然存在  那么在判断是否在频道页面 DNF Taiwan是频道页面

        hwnd_登录器 = FindWindowA子窗口_整数_文本 (0, “DNF Taiwan”)


        信息框 (“现在在频道页面 由于是D3D  我无法点击  进入游戏  按钮”, 0, , )



    .如果真结束


    ' 下面写捡物代码


    返回 ()
.如果真结束


.如果真 (FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_选区”) ≠ 0)

    hwnd_登录器 = FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_选区”)

    可可_Set点击可可登录按钮 (hwnd_登录器, 130)

    hwnd_登录器 = 0
    .判断循环首 (hwnd_登录器 = 0)

        hwnd_登录器 = FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_登陆”)

    .判断循环尾 ()
    延迟 (1000)
    可可_Set写可可编辑框帐号密码 (hwnd_登录器, 120, 130, 游戏帐号, 游戏密码, 假)
    延迟 (500)
    可可_Set点击可可登录按钮 (hwnd_登录器, 110)



    返回 ()
.如果真结束


.如果真 (FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_登陆”) ≠ 0)
    hwnd_登录器 = FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_登陆”)


    延迟 (1000)
    可可_Set写可可编辑框帐号密码 (hwnd_登录器, 120, 130, 游戏帐号, 游戏密码, 假)
    延迟 (500)
    可可_Set点击可可登录按钮 (hwnd_登录器, 110)

    返回 ()


.如果真结束





.如果真 (取进程ID (游戏启动进程名为) = -1 且 取进程ID (“DNF.exe”) = -1)  ' (1)启动进程不存在  则在判断DNF.exe进程是否存在  都不存在则说明游戏没启动
    运行 (游戏绝对路径, 假, )


    hwnd_登录器 = 0
    .判断循环首 (hwnd_登录器 = 0)

        hwnd_登录器 = FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_选区”)

    .判断循环尾 ()
    延迟 (1000)

    可可_Set点击可可登录按钮 (hwnd_登录器, 130)



    ' (2)
    hwnd_登录器 = 0
    .判断循环首 (hwnd_登录器 = 0)

        hwnd_登录器 = FindWindowA子窗口_整数_文本 (0, “_Dnf_登陆器_登陆”)

    .判断循环尾 ()
    延迟 (1000)
    可可_Set写可可编辑框帐号密码 (hwnd_登录器, 120, 130, 游戏帐号, 游戏密码, 假)
    延迟 (500)
    可可_Set点击可可登录按钮 (hwnd_登录器, 110)


    返回 ()


.如果真结束






' 思路  首先判断 _Dnf_登陆器.exe存在 还是DNF.exe存在

返回 ()

TOP

wwwwwwwwwwwwwww

TOP

謝謝分享

TOP

返回列表