SCLUB免費論壇申請-使用者論壇's Archiver

夜影o夜空 發表於 2018-6-2 02:10

Discuz 在新版MySQL無法安裝的解決方法

因為Discuz!使用的是老版本的MySQL,而新版的MySQL中使用ENGINE并放弃了TYPE函数,因此您需要按照以下步骤来安装Discuz!


    1、 将程序解压并上传至服务器;


    2、 用文本编辑器或其他编辑软件打开/install/data/install.sql文件;


    3、 将其中所有的TYPE=替换为ENGINE=;


    4、 在浏览器运行安装文件。

bossll 發表於 2018-6-2 13:35

[b]回復 [url=http://www.sclub.com.tw/discuz/redirect.php?goto=findpost&pid=291710&ptid=34408]1#[/url] [i]夜影o夜空[/i] [/b]


    你好。
建議先自行參考達人小G發出[url=http://www.sclub.com.tw/discuz/viewthread.php?tid=21646&page=1&authorid=35002][color=Blue]教你如何建独立站[/color][/url]

不需要管MySQL新與舊版本,且不需要版的MySQL任合涵數內容
只要修改要安裝該軟件數據庫名稱既可使用

以上提供參考

夜影o夜空 發表於 2018-6-2 14:48

[b]回復 [url=http://sclub.com.tw/discuz/redirect.php?goto=findpost&pid=291713&ptid=34408]2#[/url] [i]bossll[/i] [/b]


    最新版本的5.6已經捨棄了TYPE函數,所以不改的話會安裝不了,而小G分享的是舊版(5.6以下)

頁: [1]

Powered by Discuz! Archiver 7.2  © 2001-2009 Comsenz Inc.